SharePoint 2010 beta error: Retrieving the COM class factory for component with CLSID {BDEADF26-C265-11D0-BCED-00A0C90AB50F} failed due to the following error: 800703fa

So I ran into this issue after having installed my SharePoint 2010 farm with 3 servers. At first I did not want to spend a lot of time troubleshooting this and I solved it be reprovisioning my Central Admin which solved the issue. However one day later, the issue was back. after further investigatioàn this time I got an error indicating:

–> Retrieving the COM class factory for component with CLSID {BDEADF26-C265-11D0-BCED-00A0C90AB50F} failed due to the following error: 800703fa

When performing an IIS reset, the error disappears. You could schedule a iisreset, but hey let’s try to fix this. My good friend Google, found the solution on the blog of Kasper de Jonge.

(http://business-intelligence.kdejonge.net/sharepoint-2010-beta-error-retrieving-the-com-class-factory-for-component-with-clsid-bdeadf26-c265-11d0-bced-00a0c90ab50f-failed-due-to-the-following-error-800703fa)

The solution:

Go to IIS Manager, select the Application Pool for your central administration web  application and click Advanced settings, change the value for “Load User Profile” to “true”

 

Thanks Kasper for this one [:D]

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

p5rn7vb